Vorkenntnisse und Voraussetzungen

Zum Programmierung sind Kenntnisse der Sprache C erforderlich und natürlich die Verwendung des C-Compilers, um die Libs einzubinden.

Die Bibliothek

Um die NCurses nutzen können, müssen wir es zuerst mit den Developer-Paketen installieren.

Ubuntu und Debian

Unter Ubuntu und Debian stehen ständig aktualisierte Entwicklungsdateien in den Paketquellen zur Verfügung. Am schnellsten geht es über das Terminal mit apt-get oder aptitude:

sudo aptitude install libncurses5-dev