/usr/bin/perl install-module.pl ExtUtils::MakeMaker

Pascal, Basic und andere nicht aufgelistete
Antworten
Benutzeravatar
Xin
nur zu Besuch hier
Beiträge: 8472
Registriert: Fr Jul 04, 2008 11:10 pm
Wohnort: /home/xin
Kontaktdaten:

/usr/bin/perl install-module.pl ExtUtils::MakeMaker

Beitrag von Xin » Mo Feb 21, 2011 11:23 am

Ich brauche mal einen fähigen Perl-Entwickler. Gibt's die noch? ^^

Ich versuche Bugzilla zu installieren. Leider erfolglos. Das checksetup.pl-Skript gibt folgendes aus:

Code: Alles auswählen

* This is Bugzilla 4.0 on perl 5.8.8
* Running on Linux 2.6.35.11-vs2.3.0.36.33-netcup #1 SMP Mon Feb 7 08:00:09 UTC 2011

Checking perl modules...
Checking for               CGI.pm (v3.51)     ok: found v3.52 
Checking for           Digest-SHA (any)       not found 
Checking for             TimeDate (v2.21)     not found                                                                                                                                                                                                                        
Checking for             DateTime (v0.28)     not found                                                                                                                                                                                                                        
Checking for    DateTime-TimeZone (v0.71)     not found                                                                                                                                                                                                                        
Checking for                  DBI (v1.41)     ok: found v1.53                                                                                                                                                                                                                  
Checking for     Template-Toolkit (v2.22)     not found 
Checking for           Email-Send (v2.00)     not found                                                                                                                                                                                                                        
Checking for           Email-MIME (v1.904)    not found                                                                                                                                                                                                                        
Checking for                  URI (any)       ok: found v1.35                                                                                                                                                                                                                  
Checking for       List-MoreUtils (v0.22)     not found 
                                                                                                                                                                                                                                                                               
Checking available perl DBD modules...
Checking for               DBD-Pg (v1.45)     not found 
Checking for            DBD-mysql (v4.00)     found v3.0008                                                                                                                                                                                                                    
Checking for           DBD-Oracle (v1.19)     not found                                                                                                                                                                                                                        
                                                                                                                                                                                                                                                                               
The following Perl modules are optional:
Checking for                   GD (v1.20)     not found 
Checking for                Chart (v2.1)      not found                                                                                                                                                                                                                        
Checking for          Template-GD (any)       not found                                                                                                                                                                                                                        
Checking for           GDTextUtil (any)       not found                                                                                                                                                                                                                        
Checking for              GDGraph (any)       not found                                                                                                                                                                                                                        
Checking for             XML-Twig (any)       not found                                                                                                                                                                                                                        
Checking for           MIME-tools (v5.406)    not found                                                                                                                                                                                                                        
Checking for          libwww-perl (any)       not found                                                                                                                                                                                                                        
Checking for          PatchReader (v0.9.4)    not found                                                                                                                                                                                                                        
Checking for            perl-ldap (any)       not found                                                                                                                                                                                                                        
Checking for          Authen-SASL (any)       ok: found v2.10                                                                                                                                                                                                                  
Checking for           RadiusPerl (any)       not found 
Checking for            SOAP-Lite (v0.712)    not found                                                                                                                                                                                                                        
Checking for             JSON-RPC (any)       not found                                                                                                                                                                                                                        
Checking for              JSON-XS (v2.0)      not found                                                                                                                                                                                                                        
Checking for           Test-Taint (any)       not found                                                                                                                                                                                                                        
Checking for          HTML-Parser (v3.40)     not found                                                                                                                                                                                                                        
Checking for        HTML-Scrubber (any)       not found                                                                                                                                                                                                                        
Checking for Email-MIME-Attachment-Stripper (any)       not found                                                                                                                                                                                                              
Checking for          Email-Reply (any)       not found                                                                                                                                                                                                                        
Checking for          TheSchwartz (any)       not found                                                                                                                                                                                                                        
Checking for       Daemon-Generic (any)       not found                                                                                                                                                                                                                        
Checking for             mod_perl (v1.999022) not found                                                                                                                                                                                                                        
Checking for     Apache-SizeLimit (v0.93)     not found                                                                                                                                                                                                                        
Checking for   Math-Random-Secure (v0.05)     not found                                                                                                                                                                                                                        
Checking for          mod_headers (any)       not found                                                                                                                                                                                                                        
Checking for          mod_expires (any)       not found                                                                                                                                                                                                                        
Checking for              mod_env (any)       ok                                                                                                                                                                                                                               
***********************************************************************
* REQUIRED MODULES                                                    *
***********************************************************************
* Bugzilla requires you to install some Perl modules which are either *
* missing from your system, or the version on your system is too old. *
* See below for commands to install these modules.                    *
***********************************************************************
* DATABASE ACCESS                                                     *
***********************************************************************
* In order to access your database, Bugzilla requires that the        *
* correct "DBD" module be installed for the database that you are     *
* running. See below for the correct command to run to install the    *
* appropriate module for your database.                               *
***********************************************************************
* OPTIONAL MODULES                                                    *
***********************************************************************
* Certain Perl modules are not required by Bugzilla, but by           *
* installing the latest version you gain access to additional         *
* features.                                                           *
*                                                                     *
* The optional modules you do not have installed are listed below,    *
* with the name of the feature they enable. Below that table are the  *
* commands to install each module.                                    *
***********************************************************************
*                    MODULE NAME * ENABLES FEATURE(S)                 *
***********************************************************************
*                             GD * Graphical Reports, New Charts, Old Charts *
*                          Chart * New Charts, Old Charts             *
*                    Template-GD * Graphical Reports                  *
*                     GDTextUtil * Graphical Reports                  *
*                        GDGraph * Graphical Reports                  *
*                       XML-Twig * Move Bugs Between Installations, Automatic Update Notifications *
*                     MIME-tools * Move Bugs Between Installations    *
*                    libwww-perl * Automatic Update Notifications     *
*                    PatchReader * Patch Viewer                       *
*                      perl-ldap * LDAP Authentication                *
*                     RadiusPerl * RADIUS Authentication              *
*                      SOAP-Lite * XML-RPC Interface                  *
*                       JSON-RPC * JSON-RPC Interface                 *
*                        JSON-XS * Make JSON-RPC Faster               *
*                     Test-Taint * JSON-RPC Interface, XML-RPC Interface *
*                    HTML-Parser * More HTML in Product/Group Descriptions *
*                  HTML-Scrubber * More HTML in Product/Group Descriptions *
* Email-MIME-Attachment-Stripper * Inbound Email                      *
*                    Email-Reply * Inbound Email                      *
*                    TheSchwartz * Mail Queueing                      *
*                 Daemon-Generic * Mail Queueing                      *
*                       mod_perl * mod_perl                           *
*               Apache-SizeLimit * mod_perl                           *
*             Math-Random-Secure * Improve cookie and token security  *
***********************************************************************
* APACHE MODULES                                                      *
***********************************************************************
* Normally, when Bugzilla is upgraded, all Bugzilla users have to     *
* clear their browser cache or Bugzilla will break. If you enable     *
* certain modules in your Apache configuration (usually called        *
* httpd.conf or apache2.conf) then your users will not have to clear  *
* their caches when you upgrade Bugzilla. The modules you need to     *
* enable are:                                                         *
*                                                                     *
*    mod_headers, mod_expires                                         *
*                                                                     *
***********************************************************************
COMMANDS TO INSTALL OPTIONAL MODULES:

             GD: /usr/bin/perl install-module.pl GD
          Chart: /usr/bin/perl install-module.pl Chart::Lines
    Template-GD: /usr/bin/perl install-module.pl Template::Plugin::GD::Image
     GDTextUtil: /usr/bin/perl install-module.pl GD::Text
        GDGraph: /usr/bin/perl install-module.pl GD::Graph
       XML-Twig: /usr/bin/perl install-module.pl XML::Twig
     MIME-tools: /usr/bin/perl install-module.pl MIME::Parser
    libwww-perl: /usr/bin/perl install-module.pl LWP::UserAgent
    PatchReader: /usr/bin/perl install-module.pl PatchReader
      perl-ldap: /usr/bin/perl install-module.pl Net::LDAP
     RadiusPerl: /usr/bin/perl install-module.pl Authen::Radius
      SOAP-Lite: /usr/bin/perl install-module.pl SOAP::Lite
       JSON-RPC: /usr/bin/perl install-module.pl JSON::RPC
        JSON-XS: /usr/bin/perl install-module.pl JSON::XS
     Test-Taint: /usr/bin/perl install-module.pl Test::Taint
    HTML-Parser: /usr/bin/perl install-module.pl HTML::Parser
  HTML-Scrubber: /usr/bin/perl install-module.pl HTML::Scrubber
Email-MIME-Attachment-Stripper: /usr/bin/perl install-module.pl Email::MIME::Attachment::Stripper
    Email-Reply: /usr/bin/perl install-module.pl Email::Reply
    TheSchwartz: /usr/bin/perl install-module.pl TheSchwartz
 Daemon-Generic: /usr/bin/perl install-module.pl Daemon::Generic
       mod_perl: /usr/bin/perl install-module.pl mod_perl2
Apache-SizeLimit: /usr/bin/perl install-module.pl Apache2::SizeLimit
Math-Random-Secure: /usr/bin/perl install-module.pl Math::Random::Secure

YOU MUST RUN ONE OF THE FOLLOWING COMMANDS (depending on which database
you use):

PostgreSQL: /usr/bin/perl install-module.pl DBD::Pg
     MySQL: /usr/bin/perl install-module.pl DBD::mysql
    Oracle: /usr/bin/perl install-module.pl DBD::Oracle

COMMANDS TO INSTALL REQUIRED MODULES (You *must* run all these commands
and then re-run this script):                                                                                                                                                                                                                                                  
                                                                                                                                                                                                                                                                               
    /usr/bin/perl install-module.pl Digest::SHA
    /usr/bin/perl install-module.pl Date::Format
    /usr/bin/perl install-module.pl DateTime
    /usr/bin/perl install-module.pl DateTime::TimeZone
    /usr/bin/perl install-module.pl Template
    /usr/bin/perl install-module.pl Email::Send
    /usr/bin/perl install-module.pl Email::MIME
    /usr/bin/perl install-module.pl List::MoreUtils

To attempt an automatic install of every required and optional module
with one command, do:

  /usr/bin/perl install-module.pl --all

*** Installation aborted. Read the messages above. ***
Also installieren wir mal was:
/usr/bin/perl install-module.pl DBD::mysql

Code: Alles auswählen

Removing previously used /root/.cpan/build/YAML-0.72

  CPAN.pm: Going to build A/AD/ADAMK/YAML-0.72.tar.gz

Checking if your kit is complete...
Looks good
Warning: prerequisite ExtUtils::MakeMaker 6.42 not found. We have 6.3001.
Writing Makefile for YAML
    -- NOT OK
Running make test
  Can't test without successful make
Running make install
  make had returned bad status, install seems impossible

Wie bekomme ich ExtUtils::MakeMaker auf die Kiste, wenn MakeMaker nicht funktioniert!? ^^
Merke: Wer Ordnung hellt ist nicht zwangsläufig eine Leuchte.

Ich beantworte keine generellen Programmierfragen per PN oder Mail. Dafür ist das Forum da.

Paul Scheianst
Beiträge: 2
Registriert: Mo Apr 20, 2015 7:27 am

Re: /usr/bin/perl install-module.pl ExtUtils::MakeMaker

Beitrag von Paul Scheianst » Mo Apr 20, 2015 7:34 am

Perl Programmierer aus Leidenschaft ^^

Leider ist das Installieren von Modulen immer wieder mühsam, kann es sein das make oder gcc nicht installiert ist ?

Benutzeravatar
Xin
nur zu Besuch hier
Beiträge: 8472
Registriert: Fr Jul 04, 2008 11:10 pm
Wohnort: /home/xin
Kontaktdaten:

Re: /usr/bin/perl install-module.pl ExtUtils::MakeMaker

Beitrag von Xin » Mo Apr 20, 2015 10:18 am

Paul Scheianst hat geschrieben:Perl Programmierer aus Leidenschaft ^^

Leider ist das Installieren von Modulen immer wieder mühsam, kann es sein das make oder gcc nicht installiert ist ?
Och, herrje, da ist ja ein Altertümchen ausgegraben worden.
Bugzilla habe ich zwischenzeitlich installiert bekommen. Das könnte aber in vier oder fünf Wochen wieder akut werden, also lauf nicht zuweit weg :-D
Merke: Wer Ordnung hellt ist nicht zwangsläufig eine Leuchte.

Ich beantworte keine generellen Programmierfragen per PN oder Mail. Dafür ist das Forum da.

Antworten