libgmp-10dll fehlt

Windowsspezifische Probleme, WinAPI, conio.h
Asgard90
Beiträge: 13
Registriert: Mo Okt 14, 2013 1:44 pm

libgmp-10dll fehlt

Beitrag von Asgard90 » Mo Okt 14, 2013 1:50 pm

Hi Leute bin neu hier.
Hoffe ich poste meine Frage in die Richtige Rubrik, wenn nicht bitte verschieben.
Erstmal habt ihr das super gemacht mit den Turtorials.
Dazu habe ich eine Frage und zwar wenn ich denn Compiler Testen will wie im Tutorial beschrieben bekommt ich die Fehlermeldung"Programm kann nicht gestartet werden da libgmp-10dll fehlt.
Mehrmals habe ich den Compiler neuinstalliert. Auch den von sourceforge nur da merkert er beim Installer schon rum.
Path Variable habe ich gestzt ";C:\Programmieren"
Ich bin absoluter neuling und wie man sieht kriege ich das erste Programm nicht hin also seit bitte nicht so hart zur mir :-)
Hoffe ihr könnt mir helfen
Danke im vorraus
Asgard90

Edit by Xin: Betreff von "Helloworld" angepasst

Benutzeravatar
Xin
nur zu Besuch hier
Beiträge: 8453
Registriert: Fr Jul 04, 2008 11:10 pm
Wohnort: /home/xin
Kontaktdaten:

Re: Helloworld

Beitrag von Xin » Mo Okt 14, 2013 1:55 pm

Asgard90 hat geschrieben:Hi Leute bin neu hier.
Stimmt: Erstes Posting. ^^
Asgard90 hat geschrieben:Dazu habe ich eine Frage und zwar wenn ich denn Compiler Testen will wie im Tutorial beschrieben bekommt ich die Fehlermeldung"Programm kann nicht gestartet werden da libgmp-10dll fehlt.
Mehrmals habe ich den Compiler neuinstalliert. Auch den von sourceforge nur da merkert er beim Installer schon rum.
Path Variable habe ich gestzt ";C:\Programmieren"
Das ist hoffentlich nicht alles, was in der PATH-Variable steht. ^^

Wo hast Du den Compiler denn überhaupt hin installiert? Im Verzeichnis mit dem Compiler sollte ein "bin" Verzeichnis sein. Dieses "bin"-Verzeichnis soll zur vorhandenen PATH-Variable hinzugefügt werden.
Asgard90 hat geschrieben:Ich bin absoluter neuling und wie man sieht kriege ich das erste Programm nicht hin also seit bitte nicht so hart zur mir :-)
Bekommt man alles schon irgendwie hin.
Merke: Wer Ordnung hellt ist nicht zwangsläufig eine Leuchte.

Ich beantworte keine generellen Programmierfragen per PN oder Mail. Dafür ist das Forum da.

Benutzeravatar
darksider3
Beiträge: 347
Registriert: Fr Sep 14, 2012 6:26 pm
Wohnort: /dev/sda1
Kontaktdaten:

Re: libgmp-10dll fehlt

Beitrag von darksider3 » Mo Okt 14, 2013 1:58 pm

Hallo, und willkommen! :)

Was schreibst Du denn in die Konsole? Bzw. wo bist Du momentan?

Ich würde mal behaupten, dass die PATH-Variable nicht stimmt..

EDIT: Xin war schneller..
effizienz ist, wenn ich ein loch bohre und hinterher mein nachbar auch ein bild aufhängen kann... ^^
Meine Homepage und der Microblog von mir :)
Live Life dont let Life Live You!
Am meisten Aktiv in Webentwicklung und PHP im Wiki

Asgard90
Beiträge: 13
Registriert: Mo Okt 14, 2013 1:44 pm

Re: libgmp-10dll fehlt

Beitrag von Asgard90 » Mo Okt 14, 2013 2:44 pm

So hier mal ein Bild der Fehlermeldung und der Path variable
Compiler sitzt unter C:\MinGW
Bin ordner ist vorhanden

http://www.myimg.de/?img=1d0773.png

Benutzeravatar
Xin
nur zu Besuch hier
Beiträge: 8453
Registriert: Fr Jul 04, 2008 11:10 pm
Wohnort: /home/xin
Kontaktdaten:

Re: libgmp-10dll fehlt

Beitrag von Xin » Mo Okt 14, 2013 2:51 pm

Asgard90 hat geschrieben:So hier mal ein Bild der Fehlermeldung und der Path variable
Compiler sitzt unter C:\MinGW
Bin ordner ist vorhanden
Hast Du die Variable da schon verändert? Da steht ja jetzt c:\MinGW\bin.

Wenn Du die Konsole geöffnet bevor Du die Variable geändert hast bekommt diese das nicht mit. Schließen und eine neue aufmachen.
Und vorher natürlich die Konfiguration der Variablen mit "Ok" abschließen
Merke: Wer Ordnung hellt ist nicht zwangsläufig eine Leuchte.

Ich beantworte keine generellen Programmierfragen per PN oder Mail. Dafür ist das Forum da.

Asgard90
Beiträge: 13
Registriert: Mo Okt 14, 2013 1:44 pm

Re: libgmp-10dll fehlt

Beitrag von Asgard90 » Mo Okt 14, 2013 2:53 pm

Ja Variable ist geändert wie im Tutorial beschrieben habe die Konsole zich mal geschlossen und wieder geöffnet selbes Ergebnis.

Benutzeravatar
Xin
nur zu Besuch hier
Beiträge: 8453
Registriert: Fr Jul 04, 2008 11:10 pm
Wohnort: /home/xin
Kontaktdaten:

Re: libgmp-10dll fehlt

Beitrag von Xin » Mo Okt 14, 2013 3:01 pm

Asgard90 hat geschrieben:Ja Variable ist geändert wie im Tutorial beschrieben habe die Konsole zich mal geschlossen und wieder geöffnet selbes Ergebnis.
Mach folgendes doch bitte mal nach und poste die Ergebnisse:

Code: Alles auswählen

c:\>cd c:\MinGW\bin

c:\MinGW\bin>dir libgmp-10.dll
 Datenträger in Laufwerk C: ist Windows
 Volumeseriennummer: 3A75-6D03

 Verzeichnis von c:\MinGW\bin

15.02.2010  18:20           343.552 libgmp-10.dll
               1 Datei(en),        343.552 Bytes
               0 Verzeichnis(se), 24.902.017.024 Bytes frei

c:\MinGW\bin>where libgmp-10.dll
c:\MinGW\bin\libgmp-10.dll

c:\MinGW\bin>echo %PATH%
....;C:\MinGW\bin;.... (ca. 12 Zeilen)

c:\MinGW\bin>
Merke: Wer Ordnung hellt ist nicht zwangsläufig eine Leuchte.

Ich beantworte keine generellen Programmierfragen per PN oder Mail. Dafür ist das Forum da.

Asgard90
Beiträge: 13
Registriert: Mo Okt 14, 2013 1:44 pm

Re: libgmp-10dll fehlt

Beitrag von Asgard90 » Mo Okt 14, 2013 3:08 pm

Ok habe ich ausprobiert. Hier das Ergebnis
Datei nicht gefunden
http://www.myimg.de/?img=22643c.png

Benutzeravatar
Xin
nur zu Besuch hier
Beiträge: 8453
Registriert: Fr Jul 04, 2008 11:10 pm
Wohnort: /home/xin
Kontaktdaten:

Re: libgmp-10dll fehlt

Beitrag von Xin » Mo Okt 14, 2013 3:32 pm

Asgard90 hat geschrieben:Ok habe ich ausprobiert. Hier das Ergebnis

http://www.myimg.de/?img=22643c.png
Okay... da kann ich jetzt erstmal nur sagen: Die libgmp-10dll fehlt. ^^

Ich habe 136 Dateien in dem Verzeichnis.

Bleibt die Frage, warum die fehlt. Kann das c:\MinGw\bin Verzeichnis aus einem vorherigem Installationsversuch über sein? Ist die Installation vollständig gewesen?
Wo liegt denn der gcc?

Code: Alles auswählen

where gcc
Merke: Wer Ordnung hellt ist nicht zwangsläufig eine Leuchte.

Ich beantworte keine generellen Programmierfragen per PN oder Mail. Dafür ist das Forum da.

Asgard90
Beiträge: 13
Registriert: Mo Okt 14, 2013 1:44 pm

Re: libgmp-10dll fehlt

Beitrag von Asgard90 » Mo Okt 14, 2013 3:42 pm

where gcc
befehl entweder Falsch geschrieben oder konnte nicht gefunden werden.
Also ich habe es mehrmals installiert einmal wurde über DOS geupdatet. Da stand teilweise dauerhaft Error und wenn ich von sourceforge.net/projects/mingw/files/latest/download
installier haut fast nix hin, wenn ich die Häkchen setzen will poppen dauernd fehlermeldungen auf.
Im Ordner BIN habe 167 Datein
Verzeichnis ist nicht über habe den Ordner immer gelöscht bevor ich Neuinstallierte

Antworten